Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 14, 2026 - 20:30 EDT
Scheduled
On Saturday, March 14, 2026 between 08:30 pm and 10:30 pm ET Verisk, AFA applications will be performing scheduled monthly maintenance. During this period, users may experience service interruptions and will be unable to connect to SFTP, FTP, and HTTPS services using these URLs secureftp.iso.com and secureftp.verisk.com. We expect all services to be fully restored by 10:30 pm ET.
We appreciate your understanding and patience as we complete this work to maintain and improve system performance.
If you have any questions or require assistance, please contact our support team.
Posted Mar 06, 2026 - 10:57 EST
This scheduled maintenance affected: Anti-Fraud Analytics (ClaimSearch Website, ClaimSearch Match Report, Claims Inquiry, Claims Reporting - Web Submission, Claims Reporting - Integrated Submission - FTP, Claims Reporting - Integrated Submission - XML, ClaimSearch Insights (Dashboards), Research Hub, Claims Coverage Identifier, NICB, Claim Scoring, Provider Scoring, Network Analysis, Case Manager, Digital Media Forensics, Digital Commerce Detector, Digital Asset Finder, Other ClaimSearch Services).