Service disruption from Imperva affecting west coast transactions
Incident Report for ISO ClaimSearch
Postmortem

RETROSPECTIVE SUMMARY:

Incident date:  7/6/2023

Resolution date:  7/6/2023

Retrospective date:  7/11/2023

CUSTOMER IMPACT: 

Southwestern ClaimSearch users were unable to access certain url's during the outage

ROOT CAUSE:  

3rd party Vendor (Imperva).

MONITORING: Are there any improvements in monitoring and alerts? No. We did receive Pingdom Alerts but this was inconsistent since it self-corrected when Pingdom source went to a non-effected region.

Are there any improvements in the troubleshooting process that could reduce the resolution time? Not from our side. A more timely Status Page from Imperva would have helped

CHANGE: Was this incident caused by a change? No

Was the change tested in Production?

Was the change tested in Acceptance?

Is there any due diligence that needs to be done to avoid similar incidents caused by a change?

RCA CATEGORY: Vendor Infrastructure

CORRECTIVE ACTION: 

No action taken by ClaimSearch Team - Imperva temporarily routed traffic to by-pass LAX data Center

PREVENTIVE ACTION ITEMS BY POINT OF FAILURE:

Posted Sep 26, 2023 - 15:24 EDT

Resolved
Please be advised that from approximately 12:50-2:00pm EDT/ 16:50-6:00pm UTC there was service disruption from Imperva affecting west coast transactions. All services are now back to normal system processing.
Posted Jul 06, 2023 - 13:00 EDT