ClaimSearch Pinboard - Transaction Details is temporarily offline
Incident Report for ISO ClaimSearch
Resolved
This incident has been resolved.
Posted Jun 28, 2023 - 13:22 EDT
Identified
The Transactional Details pinboard within ClaimSearch Insights has been intentionally taken offline as we work to address a data quality/security concern. We anticipate this will be resolved by 6/27/2023.

We apologize for any inconvenience.
Posted Jun 26, 2023 - 14:08 EDT
This incident affected: ClaimSearch Website.