Resolved: Provider Scoring - No new data since Friday, March 13

Incident Report for ISO ClaimSearch

Resolved

This incident has been resolved. All data in Provider Scoring Insights is up to date. We apologize for any inconvenience.
Posted Mar 18, 2026 - 10:01 EDT

Identified

The Provider Scoring Service is operational but displayed data may not be up to date. We are currently working to resolve this issue. We apologize for any inconvenience.
Posted Mar 16, 2026 - 09:25 EDT
This incident affected: Anti-Fraud Analytics (Provider Scoring).