Resolved: Some of the AntiFraud Analytics applications are experiencing intermittent downtime. The Casualty Solutions applications continue to function as expected.

Incident Report for ISO ClaimSearch

Resolved

This incident is resolved and all services are operational. We apologize for any inconvenience.
Posted Oct 21, 2025 - 09:32 EDT

Update

We are continuing to monitor for any further issues. We have scaled up our resources as we process through the backlog. Thank you for your patience as we work through this issue.
Posted Oct 20, 2025 - 19:24 EDT

Update

The AWS vendor is continuing to work on resolving issues with starting up additional serverless application servers. We are actively monitoring the queues to ensure claims are being processed in the AntiFraud Analytics applications. Thank you for your patience.
Posted Oct 20, 2025 - 17:51 EDT

Monitoring

The AWS vendor has implemented a fix for the networking issue, and systems are recovering. The ClaimSearch website and Claims Inquiry are operational. Claims Submission and Match Reports are processing, but it will take some time for the queues to fully catch up.
Posted Oct 20, 2025 - 16:08 EDT

Update

The AWS vendor has deployed a fix to address issues with application server launches and is continuing to work on resolving the networking issue. We are still observing intermittent performance issues with the AntiFraud applications. We appreciate your patience.
Posted Oct 20, 2025 - 15:41 EDT

Update

The AWS vendor continues to implement mitigation steps to resolve issues with launching application servers and networking. In parallel, Verisk technical teams are working on failover to the standby environment for the affected services to restore functionality.
Posted Oct 20, 2025 - 13:32 EDT

Update

The AWS vendor is taking additional steps to fully resolve the ongoing networking connectivity issues. In parallel, they are actively working to address challenges impacting the launch of new application servers, which is required to restore normal capacity. We are closely monitoring progress and will continue to provide updates until services are fully stabilized.
Posted Oct 20, 2025 - 12:35 EDT

Update

We are continuing to work on a fix for this issue in close collaboration with the AWS vendor. Our teams are actively implementing vendor-recommended actions.
Posted Oct 20, 2025 - 11:59 EDT

Update

The AWS vendor is continuing to investigate the underlying cause of the networking issues and issues with starting up application servers. In parallel, Verisk technical teams are working on failover efforts to an alternate stable AWS environment to restore services as quickly as possible. We will provide further updates as progress is made. We appreciate your understanding while we work to fully resolve this issue.
Posted Oct 20, 2025 - 11:30 EDT

Update

Investigating : Claim Search website is currently unavailable to a major outage. We appreciate your patience as we work to identify the root cause.
Posted Oct 20, 2025 - 10:39 EDT

Update

Our technical teams are actively collaborating with the AWS vendor, applying vendor-recommended fixes, and taking the necessary steps to restore full functionality as quickly as possible. We appreciate your understanding.
Posted Oct 20, 2025 - 10:06 EDT

Identified

Our technical teams have implemented the workaround solution recommended by the AWS vendor. As a result, we have successfully restarted a portion of the affected application servers. The teams are continuing to work on bringing up the remaining impacted servers, and full recovery is expected soon.
Posted Oct 20, 2025 - 09:11 EDT

Update

AWS vendor has fixed some of the application servers and they are still working on fixing the remaining servers. The issue is expected to be resolved within an hour. Thank you for your patience.
Posted Oct 20, 2025 - 08:53 EDT

Update

Currently, the AWS vendor is actively working to resolve the issues with starting the affected application servers. Meanwhile, our technical teams are also working on an alternative solution to restore the impacted applications. We will continue our efforts to bring the applications back online.
Posted Oct 20, 2025 - 07:49 EDT

Update

We are still experiencing issues with some of the functionalities in the Anti Fraud Analytics and Casualty Solutions application, and our technical teams are actively working to resolve them. Thank you for your patience.
Posted Oct 20, 2025 - 06:55 EDT

Update

AWS vendor has recovered most of the impacted services. We have validated that significant functionalities are operational, and we are continuing to validate the application to ensure all apps are stable.
Posted Oct 20, 2025 - 05:49 EDT

Investigating

Our applications are hosted in the AWS environment. AWS is currently experiencing an outage, and the AWS vendor is working to resolve the issue. Meanwhile, we are working on identifying and implementing an alternative solution.
Posted Oct 20, 2025 - 05:28 EDT
This incident affected: Anti Fraud Analytics (AFA) (ClaimSearch Website, ClaimSearch Match Report, Claims Inquiry, Claims Reporting - Web Submission, Claims Reporting - Integrated Submission - XML, NICB) and Casualty Solutions (Discovery Navigator, WCS).