Resolved: Major outage affecting ClaimSearch Insights
Incident Report for ISO ClaimSearch
Resolved
Service has been fully restored for ClaimSearch Insights. We appreciate your patience during this time.
Posted Jan 24, 2024 - 11:06 EST
Identified
We are on track to resolve the ClaimSearch Insights issue now that we've identified the cause. Updates will follow as we progress.
Posted Jan 24, 2024 - 10:44 EST
This incident affected: Other ClaimSearch Services.